Dokuwiki

De Viquipèdia
Dreceres ràpides: navegació, cerca
DokuWiki
Dokuwiki
Desenvolupador(s) Andreas Gohr
Versió estable

1.0

/ 5 de maig de 2008
Sistema operatiu Multiplataforma
Tipus Wiki
Llicència GPL
Lloc web wiki.splitbrain.org

DokuWiki és un programa per a la gestió de llocs webs col·laboratius de tipus wiki, escrit en el llenguatge de programació PHP i distribuït en codi obert sota la llicència GPL. Està pensat per ser utilitzat per grups de desenvolupadors en general i petites companyies. La seva sintaxi és semblant a la de MediaWiki, encara que, a diferència d'aquest programa, la informació es desa en fitxers de text plans, raó per la qual no requereix l'ús d'una base dades. Andreas Göhr a juny del 2004 va crear aquest programa.

Característiques[modifica | modifica el codi]

Entre les principals característiques d'aquest programes, destaquen:

  • Gestió d'espais per continguts (namespaces) que permeten l'emmagatzemament dels documents.
  • Suport per a imatges i altres continguts multimèdia.
  • Índex de continguts automatitzats.
  • Control de versions.
  • Corrector ortogràfic opcional.
  • Interfície traduïda a múltiples idiomes, incloent-hi el català.
  • Possibilitat d'utilitzar plantilles de disseny.
  • Disponibilitat de complements (plugins) per estendre la funcionalitat.
  • Control de bloquejos per a solucionar problemes de concurrència.
  • Gestió de usuaris/es.
  • Cerca de text.

Característiques tècniques[modifica | modifica el codi]

  • No necessita una base de dades. És possible accedir directament a les pàgines del web des del sistema de fitxers.
  • Suport de caràcters internacionals en el continguts i les adreces web (URL).
  • Codificació del text UTF-8
  • Gestió d'usuaris propis o integrada amb LDAP, mySQL, Postgres amb nivells de permisos mitjançant control de llistes d'accés ACL.
  • Catxe de pàgines. Dokuwiki emmagatzema temporalment el resultat de convertir una pàgina original a HTML per millorar-ne l'eficàcia.

Requisits per a la instal·lació[modifica | modifica el codi]

  • Servidor de pàgines WEB amb suport de PHP: preferentment Apache encara que s'admeten altres alternatives.
  • PHP versió 4.3.3 o superior. Es recomana 4.3.10 o superior. També està suportat el PHP 5.
  • Es recomana disposar de les extensions gràfiques GD2 incloses en determines versions de PHP.[1]

Referències[modifica | modifica el codi]

  1. Aquests són els requisits detallats per l'autor: Requisits per a la instal·lació

Enllaços externs[modifica | modifica el codi]